StudioVeena.com Forums Discussions question about switch from spinning to static

  • question about switch from spinning to static

    Posted by icantakeoffmyhed on July 15, 2009 at 3:30 am

    i just got my pole and i switched it to spinning, then when i tried to put it back to static, the pole doesn’t spin clockwise but still kinda spins the other way around. i even lined up the screws with the X on the pole so is this normal or am i doing something wrong?

    SissyBuns replied 14 years, 9 months ago 5 Members · 4 Replies
  • 4 Replies
  • RoxyPink

    Member
    July 15, 2009 at 12:36 pm

    It’s possible that your pole is not completely secure b/n your floor and ceiling…I would try re-tightening it. When you lined up the "X" with the screw holes, did you put both of the screws in as tight as you could?

    If that dosen’t help…I dunno! Are you sure it’s a TRUE x-pole? What color is the rubber on the dome??

  • glitterhips

    Member
    July 15, 2009 at 8:30 pm

    Ive had this problem too…you have to tighten the screws super tight, like after you screw them in all the way and they wont keep moving, try to turn them a little more. My pole did the same thing after i screwed them in but if i tighten them again after ive screwed them in all the way, then my pole is stationary. good luck!

  • Foxy_Rei

    Member
    July 15, 2009 at 8:52 pm

    Also what helps is when you use the little allen wrench, put the short end into the screw so you’re using the long side as a handle. This gives you better leverage and you can tighten the screws tighter. https://www.studioveena.com/img/smilies/icon_e_smile.gif

  • SissyBuns

    Member
    July 15, 2009 at 11:55 pm

    Ive had this problem too…you have to tighten the screws super tight, like after you screw them in all the way and they wont keep moving, try to turn them a little more. My pole did the same thing after i screwed them in but if i tighten them again after ive screwed them in all the way, then my pole is stationary. good luck!

    Since when do you use static little lady? LMAO!

Log in to reply.