StudioVeena.com Forums Discussions Titanium Pole

  • Titanium Pole

    Posted by jeng on July 6, 2009 at 10:24 pm

    I recently purchased a titatium xpole. I noticed when I first got it there were a couple small spots on it where a chrome color was showing instead of the titatium finish. Does anyone know if this is normal or if this is anything I should be worried about?

    rubberstarlet replied 14 years, 11 months ago 4 Members · 4 Replies
  • 4 Replies
  • SissyBuns

    Member
    July 6, 2009 at 11:01 pm

    I wish I could help you here Jeng but I haven’t the foggiest.

  • rubberstarlet

    Member
    July 6, 2009 at 11:06 pm

    when i got my pole a few spots were the threads are, the chrome was showing. and at the top were the dome is.. but its very faintly. I haven’t noticed any more showing threw. but a youtube buddy of mine said over a year her gold pole faded a little bit. I wouldent worry about it unless it looks really poorly made or chipping

  • Jenn

    Member
    July 7, 2009 at 6:21 am

    Hey girl, I would suggest you contact X pole and let them know about the discolorations. I had a similar issue in which the TG finish had worn off my main pole within months of purchasing it. I email them pictures of the damage and they were kind enough to replace the damaged piece for free.

  • rubberstarlet

    Member
    July 7, 2009 at 7:28 am

    haha ill keep that in mind ill have to take pictures of it next time its up and check over time.

Log in to reply.